SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Unable to save my work

Whenever I try to save my work it says to ensure no other software is accessing the project then try again. Nothing else is accessing ti and it’s only on one specific project. I’ve restarted my computer so that isn’t it.

Where is that particular project located?

If you’re repeatedly getting that error, even after restarting, then the likelihood is you’re opening a project that is in a read only location. SmartEdit Writer needs full read/write access to the folder or location that contains the project. Ideally, the project should be in your Windows / Documents folder. It should not be on a DVD drive or cloud storage folder.

It is in a cloud storage folder but I’ve been using it that way for months. Any reason as to why it’s giving an issue now?

I removed it from the cloud storage folder and I’m still getting that message.

Some of the files in the project may have been set to read only while in your cloud folder. You can check for this by opening the individual project folder’s “Document” folder, selecting all files, right clicking and choosing Properties. Ensure that the read only check box is unchecked.

Another check you can make is to see if you can create a new and empty scene and add some text to that.

Just tried that and still getting the same message. I also tried creating an empty scene but that just gave another error message saying that access was denied.

Nevermind it seems to be working now. Thanks for the assistance.

The problem is back and now even when I try creating a new project it gives several error messages before opening the project and then telling me I can’t save it due to another program being open. I did the uncheck read only box and the problem persists. I even tried uninstalling and reinstalling the program but nothing.

Are you back using the cloud folder? If not, what’s the precise location of your projects?

The location of the projects is in C:\Users\mange\Documents\Atomic Scribbler. I did not move them back to the cloud folder.

This seems to be stopping and starting for you. Working sometimes and then not working other times. It sounds like there’s some process running on your PC in the background that is interfering with SmartEdit’s ability to write to the project folder. Could be an automated backup process, an over zealous anti-virus program, something like that.

All I can suggest is you look at what background apps and processes are running when you have the problem. If SmartEdit can’t write to its own project folders (which is what all those errors you’re seeing mean), then it can’t run.

Not that I’m expecting any explanation or help at this point but just informing you that before the latest update it was specifically a problem with only one project and when creating a new one. Since the new update, I’m getting the error message with all of my projects. Just wanted to let you know.

I created an account on this forum just to say I’ve had this issue too. I’m not saving to the cloud; I have a dedicated projects folder on my hard drive, though I don’t install to the default location. The folders inside (and everywhere on my Windows 10 machine) all have that black square in the checkbox for read-only, but the files inside are not read-only. I believe I read somewhere that the black square is actually “meaningless.”

I have no answer for this, and after a lot of headache, the problem resolved itself today and the program started saving again.

I love how this program organizes project data, but I can’t work on a project if I’m not sure it will save my changes. I’m actually sad to have to uninstall it and look for something else. I hope there’s a consistent fix for this in a later update.

SmartEdit Writer doesn’t make any decision as to whether to save or not. It always tries to save. This means that if it can’t save it’s being prevented from doing so by a third party.

This could be the save permissions on the folder that contains your project do not allow it, it could be because the file is locked open by another app (unlikely for a whole project), or it could be because an over aggressive anti-virus program on your PC is stopping SmartEdit from writing to that folder.

The last is the most likely if you’re not working inside a cloud folder and if you have full write access to the folder containing the project.

This is the biggest indicator that a third party is involved. SmartEdit’s behavior doesn’t change from day to day.

I wanted to test out something before coming back here. I whitelisted SmartEdit Writer’s exe in my antivirus (AVG) and the entire program directory in Malware Bytes and so far so good, no more problems saving. I’m hopeful that this is the fix, and that posting this will help others.

Like I said before, this is great software! I just started checking out the part that scans my project for redundancies and adverbs. I didn’t realize how often I used certain phrases. :joy: