Atomic Scribbler Home · SmartEdit Home · Help

Atomic Scribbler & SmartEdit Forums

Typing animation feedback


#1

The typing animation bothers me a little.

The deleting is faster in the 6 version. However, the typing itself is not smooth and glitches a bit as typing. For example: letters will lag a second before appearing and sometimes move and disappear and reappear as I’m typing out a sentence without stopping. By the time I’m finished characters are back to normal. They all save normal.

I’ve seen this type of behavior in LibreOffice’s constant auto save feature. It’s kind of bothersome. I don’t know if auto save is what caused this.

Is there something I can do to fix this on my own? Or, is it simply the programs quirk?


#2

This isn’t an issue I’ve noticed myself. I’ve seen it happen once on a machine where the CPU usage was maxed out. Every other app was also running slow.

It’s not the autosave that’s causing it, as that only kicks in every couple of minutes, and even then it’s running under the covers on a very small text file. Do you have the live spell checker running as you type – the red underline? If it’s on, try switching this off and see if that improves things.

Also, have you tried a PC restart since installing version 6?

And can you tell me a little about your PC. Operating system, and are you running a 4k high res monitor.


#3

The restart helped a bit with speed. But, the characters still hesitate for about half a second. I noticed the characters show up with an ‘animation’ to them. All other processors I’ve tried in comparison just inserts the character without any transition frames in between typing.

I turned the live speeding off and found no difference.

I run AS on a 4-core, 8gb ram, laptop. It’s screen size is 1366 x 786 running at 100% text size.

The current OS is Windows 10 Home running version 10.0.17134.


#4

Edit: Looking at a demo video for the only instant of typing, it is smoother than mine. I also messed with the zoom in/out and while the character popping in and out are still there, some percentages are more showy than others. I.e. 90% and 110%.

Edit 2: The behavior is minimum using the preview typing in settings. The other typing such as font boxes don’t do this, either.

One more thing, I tried again since last night, and it is more obvious when I write slower than fast. If I go fast a smaller amount will do this.

I don’t have any video comparisons of people typing in AS to know how it should be.

Is pagefour somewhat similar to Atomic Scribbler in terms of what makes up the program? I tried that on my laptop and it doesn’t have the character problems when typing. So, I’m wondering if I’m missing something in Windows to make AS behave like this. Considering others had problems with the .net.


#5

It’s unlikely that you’re encountering the same issue, but there’s no harm in trying the .Net solution. Run the installer from this URL: http://go.microsoft.com/fwlink/?LinkId=863262

In all probability it will tell tell you that the framework is already installed as it starts to run. If it doesn’t, go ahead with the install and see if it helps.


#6

The underlying tech in Atomic is very different to PageFour’s. The typing speed and activity in Atomic should be similar to Word. You shouldn’t see any noticeable delay at all or any animation. Were you using version 5 before this and if so did you notice a similar issue there?


#7

I used version five and had the same issue as in six. I also checked up on my .net and it is up to date.

I have not used any other AS versions under 6 and 5.


#8

So we can rule out the version 6 update as the cause. What I’d suggest is to open the task manager while you’re running and typing into Atomic. Click on “More Details” to expand the dialog and see what figures it shows for CPU and memory usage. If you’re up close to the 100% mark, then the issue is likely to be your PC performance.

task-manager


#10

I did one more test with cpu, memory, and disk. I monitored the program from: it not being open to typing. My memory is 8gb, I use a four core processor 6G at 2.5 ghz, and 1tb local hard drive.

Fresh computer desktop boot up:
5-30% cpu
37% memory
85% disk

Launching AS launcher (the actual apps numbers):
0% cpu
10-20 mb memory
0.1 mb/s disk

Opening a project:
0% cpu
104.4 mb memory (at this point the entire memory usage is now at 42% and remains there)
0 mb/s disk

Typing in the processor:
3-7% cpu
106-107 mb memory
0 mb/s disk


#11

It’s not a memory issue then. If your CPU usage had been running close to 100% in general then that would have acounted for it, but you would have noticed sluggish behaviour in many other apps by that time.

Your monitor resolution, screen size, is average as well, so previous issues that users of 4K monitors have experienced would not apply here.

That doesn’t leave anything I can think of that could be causing this. Something specific to your PC I’m afraid that I can’t duplicate.


#12

Thank you for your help. Unfortunately, I can’t use this on another home laptop to try out as they are from the same company. I could try AS out on a library computer from an eternal drive or something later on.

It could be a thing related to acer laptops in general.