SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

SmartEdit Writer 7.3 released

There are a couple of small new features in this release, along with some bug fixes. The most important fix is to issues with formatting when exporting as a single document.

A second fix addresses intermittent errors that a very small number of users experienced when using the undo feature of the word processor.

New features are:

  1. A dialog to allow unusual symbols or characters to be inserted into text (Word processor toolbar)

  2. A “Print Active Tree” option on the Actions & Tools toolbar. This allows you to print the Document, Research or Fragment trees. The button is only enabled when a tree is active, and the third button from the left on the Print Dialog opens up a configuration dialog that lets you define what gets printed (currently expanded items, everything, icons, etc.)

Download here.

The Knowledge Base has not been updated with these changes yet. Any issues, let me know.

2 Likes

Thank you so much, this looks so great! I am excited to use the update. :slight_smile:

Thank you so much for adding in the symbol button. So much easier than using Windows built in Character Map

1 Like

thanks for the update Darren!

you once wrote “When SmartEdit Writers opens for the first time it copies the Huck Finn project into your “Documents / SmartEdit Writer” folder, which is the default folder for all new projects. You should open it from this folder, not from “Program Files”.”

after i upgraded to 7.3, I tried to load Huckleberry Finn from Recently Open Projects in the Project manager, and got error messages:-

I went to
C:\Program Files\SmartEdit Writer\data\Sample Project\atomic.scribbler
which is a text file, and in Notepad changed the version from 7 to 7.3
and saved it (not as a .txt file of course, but as the original ‘atomic.scribbler’)

Then I moved the entire ‘Sample Project’ folder
C:\Program Files\SmartEdit Writer\data\Sample Project
into the default “Documents / SmartEdit Writer” folder, as you indicated, and changed the folder name ‘Sample Project’ to ‘Huckleberry Finn’ for good measure.
then I went to Open Project in the Project Manager, navigated to
‘Documents\SmartEdit Writer\Huckleberry Finn\atomic.scribbler’
and it opened without any error messages.

If you think this is worth fixing, it seems to only need changing the ‘atomic.scribbler’ file inside the Sample Folder, and making sure installing 7.3 over previous versions overwrites the existing ‘atomic.scribbler’ file.

At the rate you’re going, SmartEdit Writer is going to replace its expensive rivals, Scrivener included.

You would have encountered the error if you tried to open the sample project from inside Program Files, as SmartEdit Writer does not have write access to that folder. That’s why a copy of the sample project is made to Documents, as that folder is fully accessible.

Most users should see the sample project copied automatically when SmartEdit Writer opens for the first time, so would not encounter the error.

A very strange bug has appeared with this release. Some of the standard test files seem to work OK, although I haven’t tried them all. But all the recent files of my own misbehave drastically.

I’ll try to upload a video, since it’s hard to describe. Basically, as I type text into an existing paragraph, the other displayed paragraphs below increase their word-spacing with each keystoke, rapidly becoming much wider than the edit window, until the window is filled with unreadable, hugely-spaced words.

Oops. Can’t upload a video. Here’s a link to the video on my domain:

http://acobb.com/temp/SEWbug.wmv

Let me know if you need the file, or for me to do some testing.

Allen

Reverting to 7.0 works fine, so this is not an emergency (for me).

I see the problem. It only manifests when the text is justified and the word processor is set to “Simple View” over “Page View”. I’ll push a fix over the weekend.

Rolling back to 7.1 will work as a work around.

Thanks. I’m good with 7.0 for the time being.

The fix is ready for this issue. Version 7.4

2 Likes

Confirming – all fixed.
Thanks!