Atomic Scribbler Home · SmartEdit Home · Help

SmartEdit dropping out


#1

I’m using SmartEdit Pro 6.6, and for some reason it disappears from the Word (2013) ribbon and I have to do a repair/reinstall.

Does anyone know why this might be happening?

Mike


#2

Hi Mike, I can only guess what happens, and am in the middle to check it out. I run SE 6.x as an Add-In at Word 2010, and never had an issue. Even the version 6.6 worked fine. Well, until lately.

For the last few weeks, I’m going through the same thing. Actually since MS distributed their monthly Tuesday patch for July. So you’re not alone with it, and I guess it has to do with the last Win 10 patch.

Anyway, MS patch day is normally scheduled as the 2nd Tuesday of each month. So, we can expect the rollout of their August patch next Tuesday [14/08]. Maybe that’s when we can solve it. At the moment, there seems to be no solution at hand. At least I’m out of ideas now. :frowning:

Maybe Darren has an idea, as he is probably better informed and closer to MS as we all together. :slight_smile:

Hans


#3

Troubleshooting Update:

Since it just happened today again, I did some further research after answering you.
Well, I cannot speak for your Word 2013 version, but I got my 2010 version stable now.
You most likely have the former SE for Word version still somewhere stored.

Here is what you can try:

  • Uninstall SE for Word 6.6
  • Clean up registry, cash, etc.
  • Then go one version back and install SE for Word 6.5
  • Restart Windows
  • Open Word, open one of documents, and then open SE.
  • It will ask you whether you want to install the newer version. Just deny it, and continue with 6.5

It doesn’t disappear anymore like version 6.6 did.

Hope that helps,
Hans


#4

Hans, sorry not to respond sooner but thanks so much for this, I shall try what you suggest and it’s good to know it’s not just me!
Mike


#5

Have you both tried the solution on the FAQ page titled “I’ve installed SmartEdit for Word but can’t see it in Microsoft Word”?

https://www.smart-edit.com/Home/Faq/

This should fix the problem, or at the very least it should tell you that SmartEdit is installed but disabled.

The continuous and automatic ugrades that apply to Word 365 means that changes can come down from Microsoft without notice that cause problems. It’ll be next week before I can take a look at this, but do let me know if the FAQ option worked or showed you anythng useful.


#6

Thanks Darren. I have checked that SmartEdit is not disabled, so that’s not the problem. However, I have never tried turning off word and restarting to see if SE reappears - I would only ever notice it’s absence when I need to use it, rather than in the course of normal use of Word. I’ll do that next time SE drops off - it has happened perhaps four or five times in the last couple of months and hitherto I have run Repair each time.
Mike


#7

Hi Darren,

Yes, I’m familiar with disabled COM-Add-Ins for a different reason. Before I switched to SmartEdit quite some time ago, I used Perfect It! which had the same issue now and then. But that’s not the case here.

Never had that issue with SmartEdit until now (v6.6 only). That’s why I didn’t post anything but tried my own troubleshooting first. Had in mind to offer a solution, provided someone would experience this issue. :slight_smile:

Bottom line is that out of the blue, SE 6.6 didn’t show as a tab anymore. Closing Word and reopening it never worked, neither with Perfect It! nor here with SE.

First time, I didn’t look further but tried to reinstall it with repair option, but to no avail. That made me go for the Add-In Option and COM Add-Ins. Result: SE wasn’t even listed. It had just disappeared, but the installed application list from Windows 10 showed it as installed.

So I uninstalled SE 6.6 (via Settings, Apps), cleaned everything up and reinstalled SE 6.6 again.
That worked for some time, and then happened again. It always disappeared, never showed as ‘disabled’ in COM Add-Ins.

It just happened again a few days ago, and I was in the middle of fixing it for good when Mike posted.
The issues is apparently within the 6.6 upgrade. SE 6.5 is reliable and works like a charm. :slight_smile:

…The continuous and automatic upgrades that apply to Word 365 means that changes can come down from Microsoft without notice that cause problems <<

Yep, that’s why I figured it might be a Win 10 patch issue. :slight_smile:
However, the SE 6.5 version is safe to use, and ialways there when needed.

Hans


#8

Thanks for the replies guys. I’ll try and put together a new build next week and see is that fixes the problem.


#9

I’ve released a new version that I hope will fix this problem - 6.61. There’s no new functionality in this release, but hopefully it will fix the dropping out issue. Let me know how it goes.

https://www.smart-edit.com/Home/DownloadRelease/


#10

Many thanks Darren, and thanks for acting so quickly. Will let you know if there are still issues.
Mike


#11

Hi Darren,
I installed SE 6.61 over 6.5 and it seems to be fine. Had it disappear only once after the first opening and closing Word 2010. After opening Word again it was gone, but just disabled. Set the check mark at the COM Add-In again, and everything is O.K. since then. Opened and closed Word numerous times over the last 4 hours. SmartEdit showed as a tab every time. It opens and runs just fine. Looks like you nailed it. :slight_smile: Thanks a lot for the fix.

Hans


#12

Thanks Hans. I’m not entirely convicned this will fix the issue long term, but keep me informed of any issues.


#13

That’s a given, Darren. All it takes is another quick patch for Word, released by MS, and we could be back to the same issue. Well for now, everything works fine.

We’ll see what we have to tackle later on. With MS announcing to streamline their periodical patches we can expects some issues for Word as well.

Hans