Atomic Scribbler Home · SmartEdit Home · Help

Atomic Scribbler & SmartEdit Forums

Large project (300k words) won't load!


#1

Hi, I have just imported my main series of novels into Atomic. It loaded the first couple of times - but then it wouldn’t anymore. Atomic just hangs at the logo forever and the laptop freezes up. It loads my other project fine (half the size), though that takes a while. I think the problem started when I imported some of my notes files. Also: whenever I try to load my main project and have to shut off the computer, all my projects vanish from the project list. Is my computer is just crappy, or is this a bug?

It’s a 64bit Windows 7 i5 laptop. with 4gb of ram in case that helps.


#2

I came across a similar issue (thought with a smaller overall project size, 160,000 words).

I went into the AS project folder, and removed the .RTF files - leaving only the .DOCX files. Project opened without an issue.

I then recreated the notes files within AS. Luckily, there were not too many. Project now opens, saves and closes without an issue.

Like you, I am running 64bit Win7.


#3

Okay, this is odd. I can’t find those files and my computer is freezing up when I go into the project folder. Just going into that file crashes explorer… What’s going on? This is a folder with files numbered up to 85, but I’d not expect that to crash explorer. The rest of the computer seems to work okay.


#4

That is really odd. In the AS folder, numbered document files are .docx and note files are .rtf. Just viewing them should not bring everything to a crashing halt.

Rather than viewing with Explorer, can I suggest something like Q-Dir.

http://q-dir.com/

At least that way we can eliminate Explorer as the problem.

Can you view other directories, or is just this one specific directory?

Jon


#5

This seems basic, I know, but have you tried re-booting your computer?


#6

That is really odd. In the AS folder, numbered document files are .docx and note files are .rtf.

They may actually be in there as there are some files with different icons. I’ll take your advice and use the program, thank you. I’m starting to wonder if the computer isn’t half burnt out but it seems to be only very specific things that set it off.

This seems basic, I know, but have you tried re-booting your computer?

Quite a few times, sorry.


#7

Actually, having said that, the program looks a little… suspicious. The thing about the false positives for viruses leads to a page that kinda worries me in its language…


#8

Hi Philip,

There seems to be a few strange things going on here.

There are two separate apps that make up Atomic Scribbler: the Project Manager and the Scribbler app that works with your project (word processor, notes, etc.) The desktop icon leads to the Project Manager. This is a very light-weight app. It does nothing but list your recently opened projects and launches the second app when you select a project. The Project Manager isn’t doing enough to cause it to hang for any length of time when you try to open it. A problem here suggests a Windows problem of some kind: low spec or old machine with little available memory maybe.

If a particular project is taking a long time to load, this could be down to whichever scenes and notes were left open when you shut it down last. For a 300k word project, did one or more scene or note contain the body of those 300k words? And was that scene left open? Atomic doesn’t open any files on start unless they were previously open, so the size of a project should have no bearing on the speed of loading. The number and size of previously opened scenes and notes could have a bearing however.

A way to test this is to rename the project’s settings file in the individual project folder: “\Documents\Atomic Scribbler\PROJECT NAME\.atomic\settings.dat” Renaming this file will cause the project to open without opening its previously opened scenes. If it opens quickly, then the problem is in the previously opened content.

This sounds again like there’s a Windows problem going on somewhere. The Documents folder for a project is a plain folder with docx and rtf files, nothing more.


#9

It was the app itself not the launcher, and there are no files over about then thousand words - but there are a lot of files. Thanks for the advice, I will try it. I’m increasingly thinking you are right and it is the computer, which is really awful for me because I only bought it this year.


#10

It might be worth taking a look at the task manager to see if some large app is consuming a lot of memory.

Ctrl-Shift-Escape is a quick way to get the task mgr. Then click CPU or Memory columns to see which apps are the biggest resource consumers.

Allen


#11

The largest app is Atomic! But thank-you, Darren solved it. Removing the file triggered a bug that let me open the file with no problems, for some reason. I found out I had every file open from when I was organising the book.

Thanks a lot!


#12

RE: the every file open issue. Yes, I’ve found that it is possible to have an ENORMOUS number of word processing tabs open at the same time as A.S. I’m not sure there could be a way to prevent this from happening and retain A.S. usefulness, but I’d like to see a button that would close all tabs or close all but the current tab.

Currently, to close all tabs, you have to hit each and every “X” in each and every tab. Bit of a pain in the backside, if you ask me!


#13

Right click on the tab header and you’ll find a range of options to close all or some tabs.


#14

AHH! Sheesh! Thanks!


#15

I’m not sure there could be a way to prevent this from happening and retain A.S. usefulness

I think an option to open the project with just one window would be the best solution if it’s struggling to load! That way you can reset the system if you get stuck somehow.


#16

I’ll see if I can put something in that monitors the load time, and if it’s taking too long only open a smaller number of tabs. This would – in a sense – automate a solution if it happens again.


#17

Thanks a lot, that would be a huge help! Do you guys have a donation option or do you profit from SmartEdit in any way? It seems a little detached from your main project, so I’m not sure.

By the way, I think you may have a memory leak in Version 5.1. While I was typing for several hours today, the program started freezing and unfreezing until I had to close it. It usually doesn’t do this, but I had opened and then closed a lot of tabs during my work. I think it’s possible they stayed in the memory, and then when I opened a new tab it may have become a duplicate? I had to shut down Scribbler but when I restarted the computer it was fine.


#18

No donation option. SmartEdit is the commercial side of Atomic Scribbler - Most useful when you get to the end of that first draft. We’ll be making that more obvious over the coming months, bringing the two sides of the app closer together.

Good catch on the memory issue. I’ll take a look.


#19

Thanks a lot. It also seems to happen when I come back from standby, I think. That one has only happened once so far, so don’t quote me on it.

I’ll definitely wait and buy it when I’m ready to edit. Thank you. :slight_smile: