SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Input animation when typing has a stutter/delay

Hello! I want to put a quick disclaimer: the program is lovely to use, except for this issue. I’m an otherwise happy user.

I’ve noticed a strange lag/delay when inputting keys, especially noticeable when typing at faster speeds. It’s not smooth at all in comparison to any other program, and I can’t figure out what is causing the issue.

I’m considering that the program might struggle to run smoothly on my computer specifically, because scrolling down also has a small amount of lag. However, careful monitoring of the task manager shows that the computer isn’t struggling to run it (and has plenty spare resources), so I have no idea what could cause that problem.

I haven’t been able to find a lot of information about the issue, except for a thread from last year in this forum. Here are a few things from the other thread that I already tested or looked out for:

  • Turning off live spell-check - no difference.
  • Resolution - I’m not using 4K resolution.
  • CPU usage - the program isn’t bottlenecked in terms of CPU, to run the program or overall.
  • Version - this problem occurs in version 7.9, but it has been present (in my case) since installation, a few versions ago. Upgrading and reinstalling did not curb the problem, though it is possible the reinstallation wasn’t 100% clean.
  • Restarting did not help.

Here are a few other points of interest:

  • My computer is not underpowered to run the program.
  • The problem persists even with new projects, so it isn’t because the projects I manage are too big.
  • I don’t experience delays with typing anywhere else.

I recorded a soundless video comparison between SmartEdit Writer and a different word editor to show the difference between the two: https://youtu.be/aS7_X67ivsM

Is there something I/we could possibly do to figure this out? Thanks in advance!

Well, I also present the same problem.

I think maybe it’s because I have Windows 10.

It’s not a Windows 10 issue, but there is an issue there. It’s tied into the component that’s used for the word processor. Leave it with me for a few days and I’ll see if anything can be done to improve it.

Thank you very much! I’ll be happy to provide more info if it’s needed. I hope the issue isn’t too much of a hassle.

It turns out this delay is a deficiency in the wider component used for the word processor. Many users would not even notice it, as it’s more a different way of rendering in the word processor space than a delay as such. It’s not as clean as Word or some other word processors. My guess is that this is down to the multitude of tasks going on under the covers — the component is perhaps a little too powerful for what’s required by SmartEdit.

Unfortunately, it’s not something I can improve on or fix. Hopefully, the underlying component will be improved, but that could be some time away, and might not happen at all.

1 Like

Thanks for the explanation! I hope it will help other people, too. It’s a shame that it turned out to be this, but I’m glad to know what is causing it, it had been driving me up the wall. I’ll just try to get used to it; I like the overall program too much to switch over something minor like this.

Cheers.

FWIW, I’m using SEW on a UHD display, on a 5-yr-old tower machine with only 12GB of RAM, and I’m not seeing any delays or hesitations. The software isn’t having any problems keeping up with my fastest typing (c. 120). My completely wild guess is that this problem may be related to the video card and/or its driver. My card is an NVIDIA GTX-1060/6 running at 60Hz; it’s about 3 years old.

I hope this might help.

Allen