SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Formatting lost on export

Hello,
On exporting a document with 20+ chapters/60K words, I found that all the return and paragraph formatting was lost. All of this content was originally copied from a docx and the formatting was preserved in SmartEdit Writer. So why was it all stripped on the way back out? Is there a setting I need to change? (It still looks as it’s supposed to when editing it in SmartEdit Writer.)

EDITED to add 6/2: I figured out I can restore the paragraph formatting relatively easily once in Word. (Phew!) It’s a bit of a pain, and I think it would work better if that wasn’t necessary. (I still need to work on the document in Word before putting it in Vellum - global replace for character names and the like - so having it export as it looks in SEW would be better.)

Thank you,
Laurie

It shouldn’t be necessary to change it again in Word. Was all formatting lost (fonts, paragraphs, italics, etc.)? Normal behaviour is for the formatting of a scene to be carried across as is.

For what it’s worth, I’ve never seen anything like that happen with SEW. In fact, I can’t think of how I would make SEW do that if I wanted it to!

What application was displaying the text without the formatting – Word? If so, I assume the export operation was directed to the DOCX format. (I apologize if this is a stupid question, but sometimes something obvious slips by the best of us.)

Allen

I too have had this problem. It is frustrating, because I absolutely adore Atomic Scribbler/Smart-Edit Writer and use it for 90% of my writing. I have tried exporting in different file formats, opening said files in different types of word processors, but no matter what I try all formatting is always completely lost.
The font exports to the wrong size, and to Calibri (I use Garamond); all paragraph indentation is lost; bold and italics are gone, as well.
I have found that if I use tab-stops, those remain the same, but that is not particularly relevant to my problem, considering I do not use many tab-stops, it is just something that I have observed.

Did you ever figure out why this was happening, @Laurie or @Darren? Considering this does not seem to be a very common problem, I assume that I am doing something wrong. :disappointed: I just hope that it is not a software incompatibility. Any suggestions? I would be very appreciative.

Morrie

Hi Morrie,
I never found a solution within SmartEdit Writer. Allen’s comment led me to believe my post was not taken seriously, so I didn’t follow up. I have worked around the problem using paragraph formatting after opening the document in Word. It’s an extra step, and it would be better if the formatting weren’t lost in the first place, but it’s not that big a deal. (I am lucky in that I normally use Calibri anyway, so that part doesn’t affect me :))
Laurie

Oh, I am sorry to hear that. Well, I am taking it quite seriously --not just due to a relation in our problem now-- though I am also sad to hear you have found no solution. I suppose that I will continue to try and troubleshoot on my own. If I discover anything, I will tell you. :slightly_smiling_face:
Thank you, anyway. I appreciate your response, and I apologise for being a bother.

Morrie

Hi Morrie,

You weren’t a bother at all! I was glad to see someone else post about the issue, selfishly; you validated my experience :).

Have you tried using the paragraph formatting tool to universally repair the lost formatting? It is better than having to manually change each paragraph, even if not ideal.

If you eventually find a better fix, I’d love to hear it! I am still using SEW and appreciate many of its features. It’s pretty awesome for a free product, the formatting issue aside.

Laurie

I am happy to hear that.

I have. Definitely not ideal, but as you said, it is better.

I am using it still, as well. I haven’t been able to find anything that works better. Lovely, little thing it is. I will remember to send you a message if I manage to solve anything. :smile:

Hi Laurie,

Maybe the issue sits deper and not really with SE. Looks like you and Morrie are the only ones to experience it.

  • Have you checked whether you have all Windows patches installed and your system is really up to date?
  • Have you made sure that you have the latest .NET Framework installed?

I don’t know which of the other forum entries has the info, but in one of them, Darren has posted a link where to download the .NET framework as a response.

Check the other forum issues and then try to download the latest .NET Framework. Windows has to be up to date and the same goes for Microsoft’s .NET Framework.

Hans

Thank you for the suggestions, Hans.

I am running windows 7, completely up to date. And I have .NET Framework 4.8 installed, which I think is the most recent one, considering it updated it not too long ago.
What about your end, Laurie?

Hans,

Why would you assume that just because only Morrie and I have commented, no one else has experienced the problem? Isn’t it possible that others have, but then grew frustrated and looked for another writing platform? (Especially if they looked here first and saw that no one gave a useful response to my post?)

As for my set up, I’m on fully updated Windows 10, and have always been running a current version of Windows 10 since before my first use of SmartEdit Writer.

Laurie

Hi Laurie,

No, it’s not possible that others had the same problems, looked at your posting and gave up.

Here are my arguments, and they are not an assumption. You look at it from the wrong point and need to see the time line.
Let’s look at it from a logical point. Anyone who has issues looks here for solutions, and — if no similar one exists already — posts a new one.

I’m here from the beginning, and all you need to do is to look at the Change Log for the different versions.

  • Version 7 (January 19th, 2019)
  • Version 7.1 (February 24th, 2019)
  • Version 7.2 (July 20th, 2019)

Needless to say that the download dates are more or less identical with installation dates on computers.

  • According to your profile, you signed up for the forum on June 02.

So, apart from the very last version [7.2], SEW 7 is out there — and in use — since January and February of this year. These are quite a few months long before you even joined the forum.

Do you reall think, if there were some serious issues with exporting, nobody would have reported them during all those months, and they wouldn’t have been addressed?

Look at the change log. The only difference between v7.1 (FEB 24) and v7.2 (JUL 20) is: Microsoft .Net framework has been rolled back to an earlier version that is installed on more PCs.

Those are the facts I base my comments on, and the dates speak for themselves.

So, your problems didn’t really show up at other user’s computers. Like Allen [ATC] said, it would be hard to simulate this. He wasn’t rude, just said the truth.

If you have the latest win patches installed, and .NET Framework is up to date as well, then I don’t know what to tell you.

The only thing that just now pops in my mind might be stupid but possible. Do you still run an older version of Word (e.g. 2003) that works only with .doc files and not — like the newer ones — with .docx files?

It’s just a wild guess and I don’t know, how the [much] older versions of Word interpret the exported file during import. My own version is an older one too but I run Word 2010, and this works just fine. Reason for me to switch was that I run the Word Add-On SmartEdit as well and this couldn’t be guaranteed with versions older than Word 2010.

Hans

Hans,

Of course I think it’s possible that people could experience this problem and not post on a forum, and instead simply give up. There are alternatives to this product out there – are you aware of this logical point?

Have you analyzed the traffic to the forums to confirm your logic? Have surveys of downloaders been done to determine how many go on to use the product regularly?

The target users are not tech experts, but authors – people with widely varying tech knowledge, many of them with little tech knowledge or patience for problems. Many of them people who are not that interested in tech or knowledgeable about it, and thus may be unlikely to post on forums.

BTW, I am not one of those people. I came from the tech industry. It’s easy enough for me to post in the forum. But I did wonder if I should bother, since SEW is not the only product I could choose to use. Even creating an email and password is enough of an obstacle that some people won’t bother posting.

To answer your question, yes, my version of Word opens and creates .docx documents.

Laurie

Calibri is the default font in Word, which means if the font information is being stripped out and nothing replaces it, Calibri will be assumed when you open the document in Word.

But I can’t say more as I can’t duplicate the problem. In order to duplicate the problem I’d need to have a project that contains the issue. This would help determine if the issue were project based (something in your formatting), or an environment issue unique to some systems.

If you can produce a brief project with a handful of scenes that duplicates the issue and email it to me, I can look into it further. (info [at] badwolfsoftware.com)

Thanks Morrie.

Laurie,

You made a single post about this issue 3 months ago. I followed up asking you a question. You didn’t reply. Allen, another forum member, took time out to weigh in and also ask you a question. You didn’t reply. You disappeared for 3 months, at which point you decided to weigh in again expressing disappointment at our lack of interest in your problem.

If you’re not prepared to engage when people are trying to help you and get to the root of your problem, then how can you expect your problem to be solved?

SEW is free software. If you’d prefer to use another free software package with better support, please do.

Darren

Thank you so much for responding and offering me some help, Darren. I know that troubleshooting is time consuming, so I really, really appreciate your assistance.

I do not have Word, so unfortunately I cannot test that, but the way that you explained makes sense. I will email you a project as soon as I can. Thank you again.

For anyone following this issue, I wanted to update with saying that I emailed Darren a project, with an example of the problem. He identified it as a bug in the software caused by specific paragraph formatting, and that due to that it was dependent on the settings of the user. (Apparently @Laurie and I must both use settings that are not as common for most of the other SEW users, that explains why not many people were encountering this bug)
He will be working on a fix for it, and the earliest we might see an update will be sometime during the first week of September.

I want to thank @Darren, @ATC and @Hamaer for all of the assistance. I appreciate it!

Morrie

Late to this party, although my FIRST export experience was an AWFUL lot like @Morrie and @Laurie. I didn’t follow this discussion with any degree of fervor because I’m stuck neck deep in a programming project that I should have finished three years ago. No time for writing. So, I haven’t opened every SmartEdit Writer forum update notice. Just the way that it is, time-wise for me. But right now, a data revival utility is running and I’ve got some moments to kill. Sooooo, I opened the latest SEW Forum update notice and checked all the recently updated threads. Including this one.

I had the same problem. I accepted a reformatting task in Word as a minor nit when I exported it and found my careful formatting was toast. I even posted here about it. The prevailing opinion THEN was that it was a singular experience and not one that bothered me a lot. My book was only seventy something pages. It gave me a chance for one last editing pass. Now, it MIGHT have had some effect on why the 500+ page book I’m writing for the second eBook hasn’t seen screen time in forever, but I blame it on my boss wanting some programming for his bucks. Certainly, I assume people asking for help continue to monitor the place they asked. But sometimes life interferes. I think Hamaer does yeoman service here. But the one post that the experience was singular to @Morrie and @laurie was wrong. Otherwise, his and Darren’s advice were spot on. Glad to see that the due diligence was done when the evidence was collected and a fix to OUR problem is due shortly.

Means I have run out of excuses not to buck up on the programming and then get back to that book!!

“should have finished three years ago” … now that sounds painfully familiar!

But what’s this … writing a book interferes with a multi-year programming project? That sounds painfully familiar, too. In fact, in my world they both interfere most synergistically with each other. I think some efficiency expert once said that the longer the timeframe of a project, the lower the priority it receives. There’s always something more immediate to take precedence.

Thankfully, I still haven’t lost all the formatting in any of my SEW projects, but the glitch does sound fascinating, especially as it apparently depends on certain style settings. Since Darren is already fixing it, I hesitate to ask what conditions were required, but these are the kinds of bugs that make software development so much fun. (Or not…)

Happy writing and programming. Weirdly, I find that both activities seem to use the same muscle.

Allen

Allen,

I’m a one-man programming shop that handles, at this point, only a few clients. I’ve fired a few, had company sales to American conglomerates phase me out of a few, kept a few. One pays the medical bills around here and I’ve been doing their systems software for close to 35 years at this point. I’ve been ‘trying’ to write a replacement for the system software there since a tentative go at it in 2009. And a second try in 2012 and a third one in 2016. Since the existing software does the job, the inertia plus the need for some new analysis or another always seemed to crop up. Unfortunately, the misbegotten entity that is Windows 10 has taken all the air cushion out of the rewrite and I need it yesterday, with even yesterday being about 18 months too late.

I exported my book about cataract surgery to Word format to do the finishing touches for publication on Amazon. And when I brought it up, all the formatting I’d been ever-so careful to create in what was, at the time, AS, was gone. Poof, disappeared. I posted in the forum, then an AS forum, and Darren wasn’t able to recreate it. I simply abandoned any testing to define the culprit and got to the task of one more editing pass while formatting it in Word. Which was, in itself, a waste of time, as I ended up doing it again in Sigil.

None of this roiled me up much. I didn’t know what to expect. Formatting and proof-reading went hand in hand, and when you are editing your own work, you need somewhere between a hundred and a bazillion passes to maybe produce OBVIOUS error-free text. Been doing the writing gig in one form or another for almost fifty years at this point. THAT has never changed because we always see what we wanted to see, not what through our fingers to the media. I was 15 proof-reading my boss, the Hall of Fame sportswriter and broadcaster Ken Giles. Even he needed fresh eyes and he was the best.

I always lollygagged the book-writing. I’d exorcise my ranting muscle in my blog. But I never got caught up in Twitter and Facebook. I’d still be sitting with a dozen books in partial disarray if one of my old newspaper pals hadn’t egged me on … which reminds me that I need to kick him in his can over his first novel STILL not being available for purchase. He reminds ME that my book about binge-watching TV or the wishography about my years coaching rep softball or the YA novel about walking in other people’s boots or the lacrosse book or the novel about my year in Radio or my collection of my Bridge columns or … well you get the drift … would be finished already if I wasn’t watching TV so much. Sigh. He’s right of course

At least I keep the reading to computer forums and the reading room. Which reminds me …

GM