SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Font color problem

Hello,

This started happening on one of the last few updates.

When I open a new scene on one of the projects I’ve been working on, I start typing, and the font color is in black. I’m in dark theme, so then have to go into font color and change it back to white. Then it stays white.

I’m pasting a screen shot at the end.

Thanks!

image

I haven’t been able to duplicate this issue, but it has come up once before. Is this happening every time you create a new scene or sporadically? And does it happen if you close and re-open the scene or only when it first opens after creation.

I use the dark theme as well. I had to change my text color to Automatic at the folder level and then it seemed to work after that.

Sorry for the delay in response, but I’ve been off the grid for a bit.

Darren: I have three projects open and it seems to happen now every time I open up a new scene in each project. Occasionally even scenes already created, when I start typing in extra stuff at the end, it’ll be in the wrong font color. If I close and re-open the scene it’s still in the wrong font color (unless I’ve changed it). Now I just hit ctrl A (select all), change the font color to white, and it seems to be fine forever

MikeM: I did what you suggested, but it hasn’t worked for me.

Glenn

The dark theme doesn’t actually change the font color at all — it’s a display setting independent of the document. The underlying font color in the document remains the default color, which is dark gray (almost black). As you’re manually changing the font color to white, if you switch the dark theme off, your font color will remain white.

I still can’t duplicate this. What’s you system / spec Glenn? Windows version, etc.

Hey,

I’m using the average Windows 10 Home on a Lenovo Thinkpad with a touch screen. Nothing weird.

It has the latest windows updates they periodically push through.

Is this happening for every project? Say you create a brand new project, is each new scene affected straight away?

As a test I just created a new project, then clicked on scene 1, and started typing. It was the wrong color. (I have a screen shot of that below.)

This is where it gets really weird. I type and type then when it gets to the end of the line, it will change the text I just typed to the right color, while continuing in the same wrong color on the line below. It’ll keep doing this as long as I keep typing. I hope I’m describing this well enough.

Also, I not only just clicked on “Scene 1” but when I created a new scene in the test project, it was immediately in the wrong color.

I hope this helps. Here’s a screen shot:

Here’s a screen shot of what I was attempting to describe.

The first line started in that blackish color, then when I got to the end of the line, the line changed to the whitish color but the font color stayed black.

Very strange, I know.

Thanks Glenn. Does the same thing happen when you type into notes?

I think it’s linked to the paragraph settings you’re using. The lines of text are very close together and seem to be triggering the issue. If you try changing the paragraph settings to have spacing after the paragraph (even 2 pts), this might fix it. Similarly, changing the view from Simple View to Print View seems to fix it.

It’s a bug, but you should able to work around it by adding some paragarph spacing for now.

The notes seem to work fine.

I think I’m using the default paragraph settings in all my projects.

I’ll try what you suggest.

Thanks!

Hi Darren,

I finally tried your suggestion and the text color looks just fine now. But it’s not underlining in the right color. I tried it at 1, 2 and 3 spaces after the paragraph. The text color worked in all 3, but the underlining was screwed up. I’ll send a couple screen shots to show you.

This is right after creating the scene with the paragraph default to 3:

Then I hit return and it underlines it (it’s underlined above you just can’t see it):

Then I try to underline “Part One” and the underline bit is in black so can’t be seen.

Here’s how I have the default scene settings in these screenshots.

I’m going to stick with how I was doing it before, with manually selecting all and changing the color. It’s only a couple steps, but like mentioned elsewhere, another step is added once it’s exported (having to change the color again once it’s in word). It would be nice if this was fixed.

Am I really the only one having this problem? That seems unbelievable.

Thanks,

Glenn

I can duplicate the underline issue. It comes and goes, but only when you’re using the Simple View. Page View seems to be working correctly, even for underlines – very strange.

The dark theme – despite appearances – doesn’t change the underlying document font color. It only changes the display color, something that does not form part of the document itself. This is why a bug like this can manifest sometimes but not every time (Simple and Page View, for example).