SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Export is all Capitalized

When I export a portion of a project or the entire thing as a single document, the output is all capitalized. Anyone have any insight into why that’s happening?

1 Like

Wow. Welcome to the forum, mperalty. That’s a new one on me (just another user), but I’m sure our intrepid developer will respond soon. Things tend to get fixed very quickly around here!



Thanks. Yeah. Here’s a quick screen recording showing my issue -

I’ve tried Arial as the font and exporting it. I’ve tried Doc and Docx and putting them in Google Drive and opening them for the same issue.

Very strange problem - one I’ve never seen before. Can I get you to create a brand new project and add one sentence to a scene (not pasted, just typed), then export that as a single document as docx and as a txt file and see what the outcome is.

So I figured out the steps to reproduce the issue. Typing in a normal document doesn’t create the issue, but if I paste text from my Google Docs into a project, then I end up with exports that are all capitalized.

Weird one. I can reproduce it copying and pasting text from Google Docs but not from a Word or LibreOffice document on my PC. Very odd. Maybe it’s a Google Docs “Feature?”

Very, very strange one this. There’s something being pulled in during the copy/paste from Google docs that the SmartEdit word processor identifies as small caps formatting, which is then being saved as part of the export. But… it’s not being used when rendering inside the word processor itself. It’ll take a while to track this one down, as the word processor in SmartEdit is an external control, but I’m looking into it.

1 Like

Any more insights into this? Any easy work around? I have over 40k words in the editor… :blush:

No update as yet. The fix for this could take a while, as it depends on a third party making a change as well. Could easily be a few weeks.

1 Like

This issue is fixed in version 8.5:

New scenes copied and pasted from Google Docs will not have this issue at all. Existing scenes that were copied from Google Docs before this release will need to be re-saved to eliminate the problem. To do this, open a scene, make a small change such as adding a space or a new line, then close the scene, thereby forcing a save for that scene and removing the problem.

This has fixed it for me. Thank you so much!