SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

Bug while installing (Windows 10)


#1

Hello! Hope I got this in the correct place.

Trying to install SEW, it downloads well and I start the install. It extracts the files fully and then it cancels. I get the following error message:

“Your computer does not meet the requirements. Supported operating systems are W10, W8.1 and W7 (W8, Vista and XP are not supported). Setup cannot continue. Please click Cancel to Exit.”

Except I’m running on W10. W10 Pro 64-Bit 10.0, Build 10586 to be specific. I’ve restarted my computer, re-downloaded and tried another install, tried installing it in different folders, nothing works. So now I come here.

My setup:
8gb RAM
i5-4690K 3,5GHz, 4 cores
Gigabyte Z97P-D3
AMD R9 380 4GB

All my drivers are up to date, and I haven’t had an issue like this before with any other program. Thank you for reading.


#2

Part of the installation involves installing the latest .Net framework from the Microsoft website. The message you’re seeing means that this failed because something on your system is not up to date. It could be a missing Windows update or something similar.

You can perform this step directly yourself by running the .Net framework install from the link halfway down this page on the Microsoft website. This way, a more detailed error message will appear telling you what, if anything, is missing or wrong on your PC to cause the failure.

If the above inatllation works without issue, you should try running the SmartEdit Writer installer again and it should work.


#3

It’s sadly not letting me install the .Net framework version either. Says it’s not compatible with my OS. I’m not sure what I’m doing wrong here, and I tried looking for the latest versions myself but none of them work. I had a couple of windows updates that I hadn’t checked for, installed all of those but none of them fixed the issue.


#4

Tell me about your device. Is it a lap top, desktop, Surface Pro tablet?


#5

It’s a desktop, I listed some specs above but if there’s anything else you need just let me know.


#6

One thing you could try is to first install the .Net package that precedes 4.72. You can do that from this page: https://www.microsoft.com/en-us/download/details.aspx?id=56116

After that installs, try the link I posted earlier for 4.72 again. Beyond this, I don’t have any suggestions, as installation issues with this package are outside our control.


#7

Tried it, got the same error for that one as well! I tried 4.7 too, same issue there. I’m really scratching my head here, but thank you for trying. Seems like I’m not gonna be able to use the program which is a shame


#8

Actually, it sounds like you aren’t going to be able to use anything that requires a modern .Net package, which could be problematic in the not too distant future.

To me, it sounds like there is something wrong with your operating system. It might be worth spending some money on figuring out why. Where I live, there are a couple of small PC repair shops that could do this sort of thing. There might be some near where you live.

The fix could be as simple as reinstalling the Operating System or downloading an appropriate missing or corrupted file. But if you aren’t comfortable doing that sort of thing, then a shop like that might be your best bet. I’d tell them to call you once the bill for their services exceeds whatever limit you set. Most of those shops are willing to work with you on something like that, in my experience.


#9

Yes I’ve been googling similar things for hours and the only answer I found was a re-install of my OS. Which is a pain. Gonna have to wait and see what I’ll do there. Thank you