Atomic Scribbler Home · SmartEdit Home · Help

Atomic Scribbler & SmartEdit Forums

Atomic Scribbler Version 6 Released Today


#1

The changes in version 6 are centred around usability — making Atomic Scribbler more intuitive and easier to use, for new users as well as regular users. This release also includes a Microsoft Framework upgrade which will help with display issues on high-res monitors.

System requirements have also changed. Atomic Scribbler version 6 will run on Windows 10, 8.1 and 7. It will no longer run on Windows 8 PCs that have not run the Windows update to 8.1.

The website (Knowledge Base and screenshots) will be updated over the next few days.

Download here

Changes include:

  1. The Research tree has been moved to the right section so that it can be visible at the same time as the Document tree.

  2. A set of Up/Down buttons have been added to the main toolbar to switch between different views in the right section. The buttons are for Research, Notes, Daily Word Count and SmartEdit (if you have SmartEdit installed).

  3. An option now exists to switch off the Start Page. [Settings dialog] A number of users were not finding value in the Start Page, so this option allows them to remove it.

  4. Bookmarks, Images and Files can now be added to the Document and Fragment trees. While my intent was to keep all of this material in the Research area, opening up the other trees always more flexibility. I’ve found myself wanting to add the odd ‘reminder’ image to a folder in the Document tree.

  5. Changes to automatic backups: an option to take only one backup each day instead of multiple backups each time you close, and an option to exclude the current project from automatic backups. [Settings dialog]

This is an important change as the frequency of backups was too much for some users, especially when backing up to a cloud folder. With these new options you can be sure you always have a single up-to-date backup each day of your important projects.

A full list of changes is in the Change Log.

Any installation issues, please post them here.


#2

Just upgraded. I really like the changes to the UI. It’s too early to say it’s problem-free, but a quick, superficial tour of the thing did not reveal any problems.


#3

Loving the functionality of having the Research material visible to the right. Really ups the usability to another level. No issues upgrading on Win7 or Win10 machine.


#4

I’ll 2nd that. I love the research tree on the right also. Only problem is now I’m going to have to redo a lot of the videos in my course. :thinking:


#5

Upgraded, no problems. Very much appreciate the move of Research. Everything seems to be working perfectly.

Two small usability observations, which I probably should have reported long ago:

  1. When searching (or replacing), the light blue highlight is extremely hard to see when the hit result happens to be narrow (e.g., searching for single quote, exclamation point, slash, narrow letters like i, l, I, fullstop, comma, etc.). I would love to see a more contrasting color for highlighting hits. Like orange or pink.

  2. Along the same visibility lines as #1, when the ^ button is pressed at the far right of the toolbar, to collapse the toolbar, a new user with a large display may take a surprisingly long time to notice the tiny pushpin, because it only appears when he has clicked on a menu item far to the left.

Thanks for the improvements, and for the swift and painless upgrade procedure.

Allen


#6

Just noticed – when I click Project Manager, it opens underneath the main AS app.

Allen


#7

Project Manager loads in front only if invoked from an instance of AS that had previously shown the PM in front. That is, if you switch to a different instance of AS and click PM, it doesn’t load in front. But if you bring it to the front (e.g., by clicking on it in the Taskbar), the next invocation will load in front. If you then switch to a different app or instance, the next load will not be in front.

Hope this helps.

Allen


#8

Good catch Allen. :+1:


#9

Just upgraded and found an issue, Darren. After opening the new AS 6, I pulled my test project part up. Upgrading to V6 was no problem.

Yet, when I ran SmartEdt [Punctuation Check], its result panel stays on the right side where the Research section of the Word Processor was before I pulled SE up.
[See image below]

Closing AS and opening it shows the Repeated Words result panel, just without any data in it. I can’t get the initial setting back.
[See image below]

Hans


#10

Additional info. Upgraded the current project as well as Huckleberry Finn to AS 6. The SE panel for repeated words remains there at any existing project I open with Word Processor.

Clearing Win10 cache didn’t bring any change. Thought that it could be just an issue with the individual project where I ran SE’s Punctuation Check. That’s why I upgraded all other projects [successfully] and opened them again. Yet not change.

OS: Win10 [Home]


#11

That’s by design Hans. I haven’t updated the website yet with the new screenshots, but the right section is controlled the same way as the left section now - from the new buttons on the main Project toolbar, shown below.

as-toolbar

You click the Research section to bring it to the front, or the Notes or Daily Word Count buttons to bring that to the front. The active section is remembered on close and re-open and is its button is always down.


#12

Darren, I didn’t even look at the Knowledge Base as I could imagine it takes some time to update everything next week. Instead I oriented myself on the list of changes you posted, and played with this.

Problem was that I couldn’t get the Research panel back when clicking the Research button at the Project panel. The R/H panel view got stuck and didn’t budge at all. :slight_smile:

However, everything is fine now. Something must have happened during installation - or a hiccup after opening and running SE within AS.

Bottom line is, not only did I clean up Win 10’s cache, but was brutal and cleaned the Registry too. Then shut down the PC, and everything was working as expected after restarting Windows. :slight_smile:

BTW, thanks for that great design. It’s really way more effective for the writing flow. I love it.
Let me know when the Knowledge Base is updated, so I can create an updated user manual. I could do my own screenshots of course, but using your Knowledge Base content makes sure that the manual is exactly mirroring the online version. :slight_smile:


#13

Let me know if it happens again Hans. That part of the app should be bullet proof.


#14

@hamaer Had an identical problem on my Win 7 machine. Everything running perfectly on Win 10. Solved it by reinstalling NET 4.72 Framework and doing a cold reboot. That seemed to solve the issue.


#15

I don’t see these arrows. Are they supposed to be in the Project Toolbar?


#16

It’s the 4 new buttons shown above Viki. Up/Down refers to the state they can be in – only one pressed down at any one time


#17

Ah, I was thinking up/down as in arrows to cycle through those 4 options in the right sidebar.

Not a bad idea anyway. Somewhere near the right sidebar, arrows to quickly go through them. :slight_smile:

Sorry for the confusion. :roll_eyes:


#18

Hello - new to Atomic Scribbler.
Quick question which may just be related to the new release - the bookmark function doesn’t seem to be working… is that just me, is it working ok for everyone else?
I can add a bookmark ok - the popup appears, I enter url and title, click ok and it appears in the tree. But if I double-click to open I just get a popup error message saying ‘unexpected error’. Same problem in Document, Fragments and Research.
No problems adding or opening an image or a file.
Many thanks


#19

When you click a bookmark link it launches your default browser with the URL. Do you have a similar issue with opening an image you’ve added? This works in the very same way.

Also, which operating system are you using and which browser do you use?

If you could send me a copy of today’s log file to info at atomicscribbler.com, that would help. Details on where the log file is can be found here: How to report a bug in Atomic Scribbler


#20

Hi Darren
Will do.

Many thanks!