SmartEdit Writer · SmartEdit for Word · Help

SmartEdit Forums

An exceedingly annoying error


I’ve experimented with this quite a bit and I can’t get around it.

I started work on a project I hadn’t worked on in a few months. The fonts in nearly all the scenes, both in the main text and research, were in Arial. My eyes in the meantime had gotten used to Georgia font. So I went back and switched every scene (a lot of scenes, it took me awhile) to Georgia font. It looked wonderful. My eyes were much happier.

Then I closed all of the scenes to clean up the display, and when I opened up a few scenes again they were all back in Arial font! It’s like the program got stuck on the Arial font because it’s what it originally was (very fond of Arial, alas!) and now I can’t get it permanently into Georgia font.

I’ve tried everything I can think of: changed the font to Georgia, then saved it with control S, closed the scene, then opened it back up again hoping it wasn’t still in Arial. But it was. I tried doing it in both page view and simple view, but it still doesn’t make it permanent.

Urgh. What to do?!

I don’t think the program was always this way. I remember being able to change the font and closing scenes and having it become permanent. But I could be wrong.

If you can fix this, it would be wonderful. (Assuming I haven’t gone crazy and there really is something to fix!).



It sounds like the initial problem was to do with the default font for scenes. If your scenes had all been written with Georgia font set as the default, and the Global default had then been changed to Arial, each scene would then open as Arial. The fix to address this would then have been to change the Global default back to Georgia, not to adjust the font for each individual scene.

Do you have a backup you can roll back to to try this?

Hey Darren,

I don’t understand what you’re asking me to try.

I originally had the default scene set-up as Arial font and was happily writing in Arial. I then changed the default scene font to Georgia, so when creating new scenes the font is in Georgia, which is precisely what I want.

The problem is the scenes previously written in Arial that I can’t save to Georgia font. I can change it while the scene is still open, but then when I close and open the scene it’s back to Arial.

Yes, the default was originally Arial. Now it’s Georgia. I’m not talking about new scenes (they are in Georgia and work fine). It’s scenes I’ve already written in Arial, that I can’t change to Georgia. At least not after closing and opening them up again.

We’re talking about writing an entire first draft of a novel in Arial font I now want to change to Georgia, but it won’t let me. Every scene written in Arial is stuck in Arial now at least while in SmartEdit. That’s the problem. I’m sure the default font was Arial when I created the scene. So it’s like it’s stuck in that groove I don’t want.

When scenes are using the global default font rather than a font you set yourself at the scene level, the font will change automatically whenever you change the global default font. In your case from Arial to Georgia.

However, if at any point you have set the font at the scene level, the global no longer applies and changing the global will not change the font for the scene. (This is probably why changing the global from Arial to Georgia did not change older scenes in your project) For this reason, it’s always better to set a global font and leave it at that — to never start adjusting fonts at the scene level.

The global default font works in the same way as the default font in Word. It’s never saved to the document itself, it’s an application setting. The only font information saved is that the global is to be used — whatever that might be at the time.

But… there does appear to be a bug that is preventing you from changing the font when you do a select all, which is what I assume you’re doing. I’ll have to look into it to see what’s going on here — may take some time as I won’t be working on SmartEdit Writer for a few weeks.

Hey Darren,

I figured out a simple work around.

Rather than hitting Control A and merely changing the font, which was then reverting back to whatever it was originally after closing the scene, now I hit control A, change the font, copy, then delete the original text and paste in the text again with the changed font. This way it stays the new default font (in this case Georgia). So hurrah! One extra step but it seems to work.

BTW, that problem with the text color as black when opening up new scenes in dark theme with simple view (a thread a long time ago), is that going to be fixed? I did try your suggestion tweaking paragraph settings, but it never did work.


That’s good news Glenn. I’ll try and get a fix in for this in a couple of weeks.

The font colour issue is ongoing. Unfortunately, the fix for this is not mine to make and lies with the makers of the word processor component. I’m hoping to get this fixed soon, but don’t have a time frame.